Skip to main content

Site Navigation

Your Account

Choose Language

Discussion Topic

T660 ac blows hot at highway speeds

I have a 2013 t660 that the ac bows hot air while while at highway speeds

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0

Comments:

Yes charged and brand new compressor installed

by

Add a comment

3 Replies

is it charged? is the compressor running?

Was this reply helpful?

Score 0

Comments:

Yes charged and brand new compressor installed on Thursday night worked fine Friday then started blowing hot air again on saturday

by

May be a bad temp adjustment switch or a problem with the little door in the hvac unit it controls. I remember from driving 2009 t600 and earlier t800 that i could never get cool air. It was either cold or hot.

by

Check it today looked like clutch was not working right on new compressor and the line was frosting up on the out side as far back as I could see

by

Bad thermostat? 2013 year model should be under warranty, dealer can't figure it out?

by

I believe that when the system freezes up it means that there is not enough refrigerant which would make the core ice over as well and prevent air from going through it.

by

Show 1 more comment

Add a comment

Many things can be wrong with an A/C system to make it not work perfectly, a proper diagnoses is needed before repairs can be done. They shouldn't just be throwing parts at it.

Was this reply helpful?

Score 0

Comments:

Thx interstate 5trucker I agree with you but right now all the parts and labor is only costing kw . All this is under factory warrnty. I just wanted it fixed that's why I ask on here

by

Add a comment

I have a 2013 T800 doing the same thing..what did you figure out on yours

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Your will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 41

All Time: 3,812