Skip to main content

Site Navigation

Your Account

Choose Language

Discussion Topic

over head adjustments?

I recently had rack run on 12.7 det with 55k on inframe, motor was running good before overhead ( should of left it alone) now it feels like it sputters lightly in low rpms and dosent pull hills as strong. Any suggestions on what might of been adjusted wrong, shop where it was done said try running it awhile longer to see if it loosens up some. Not crazy about that solution but its not running that bad that it needs to be put back in shop right away

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0
Add a comment

3 Replies

Man, that sucks. Not an expert, but I'd first be checking on having good air and fuel. If it's something else I'd doubt it would get better with time.

Was this reply helpful?

Score 0
Add a comment

See if it loosens up? From what I know, on a Detroit when the valves get out of adjustment, they tighten up, not loosen up. If I am wrong someone please correct me.

Was this reply helpful?

Score 0
Add a comment

Did the mechanic do this when the engine was cold? Sometimes adjusting the overhead when the engine is cold....if the mechanic sets the valve lash too tight as the engine heats up and the metal expands the valve setting will tighten up. I always run the over head on my N14 after coming off the road or run it till it's hot then set the valves so that when it reaches operating temperature it's where the adjustment is suppose to be.''italic text''

Was this reply helpful?

Score 0
Add a comment

Join the discussion

bob will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 396