Skip to main content

Site Navigation

Your Account

Choose Language

This houses general site questions, issues and feature requests.

218 Questions View all
Discussion Topic

Why gauges stops working?

Bought Volvo 660 with problem.It's 2001 Volvo,660 with cummins N14 Celect.While driving,info display stops showing trip millage and fuel economy and water temp and oil press gauges turn down(stop working). Sometime it takes 10 milles,some time 300 milles before they start working again.Info display does'nt show any engine fault.When I run system diagnosis, it shows"MID 128 not responding" and none system"MID 127 not responding.Changing water temp and oil press sensors did not hellped. Any Idea???

Thank You!!!

Jan

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0
Add a comment

3 Replies

I had to replace the wiring harness to my ecm to fix a similar problem.

Was this reply helpful?

Score 0
Add a comment

I drove a 2000 660 with similar problem. I found it was the connection from the wiring harness to the back of the gauge cluster. I wedged a piece of toothpick along the side of the connector to stop it from wiggling and that worked for a year.

Was this reply helpful?

Score 0
Add a comment

poorly designed connectors. Check the metal parts of the connectors to the gauge cluster, and other plugs you run across. Snap them back in place tight and firmly and tape them tight against each other where possible.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Jan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 16

All Time: 2,032