Site Navigation

Your Account

Choose Language

Discussion Topic

Cruise Control over speed, Chugging, Fluctuating?

I have a Detroit 12.7 99 year model. Freightliner classic. When i set the cruise at any set point, it will sense ecm isnt at the correct speed and then give it throttle and then abruptly let off when it detects its over the set point. and sometimes intermittently chugs trying to stay at the set point. My gps will be right on the money while this is happening. And my Scangauge shows the MPH fluctuating down 4-6 MPH below set point. And the Speedometer will fluctuate also. The Detroit shop tested the ECM which is only 6 months old, and its good. then checked wiring harness and said its good also. Also they ran new wires from sensor to ECM just to make sure they didnt miss anything in the wires .Also Speed Sensor was changed Still the problem persists. Also when the cruise is off and im using the pedal, the speedo and scangauge still fluctuate down 4-6 MPH, but there isnt any chugging. Anyone have a direction that i should be looking? Thanks, S

Update

Turned out to be the Tone wheel in the transmission was loose. Removed the yolk off the tranny, and cleaned everything, and then tightened the heck out of it. works perfectly now

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 1

Comments:

Like I said below, speed sensor out of adjustment.

by

Add a comment

1 Reply

Speed sensor is bad or out of adjustment, or wiring to speed sensor is grounding out somewhere.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Steven will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 4

All Time: 330