Site Navigation

Your Account

Choose Language

Discussion Topic

Why am I losing power and backfiring?

I have a 1998 Series 60 with 825,000 on engine re-uild. This last summer I had a guy "tune up" my ecm, but he didn't do it properly, as it has belched black smoke when I throttle up since. Today I was coming down I-65 in Indianapolis, IN and went to pass someone and I lost power and it was like my truck backfired. Now I can cruise along for a while, but when i go to give it more power it loses power and backfires. I am idling at the Waddy, KY Flying J and the truck is running fine while I am sitting here. What could be causing this loss of power and backfire?

Got the truck back and he replaced the air filter and the air inlet hose to air compressor.

I'm bobtailing but have power and can hear the turbo spool up.

Everything seems ok so far.

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0

Comments:

I'll do that. Do you think that would do it only when I am trying to give it more power like going up an incline?

by

Add a comment

5 Replies

check power fuse at battery may be corroded causing low voltage to ecm i had a 98 shaker do that before

Update

yes mine did exactly what your saying light throttle or idle its fine hit any grade or overpass it sputtered and almost died. late 90's were bad for fuse going green from road salt

Was this reply helpful?

Score 0
Add a comment

You said you have your ECM re-tuned....is it still got the same settings? I would get this corrected if you haven't turned it back down...

Was this reply helpful?

Score 0
Add a comment

I plan on getting the ECM re-tuned as soon as I possible can. Problem is I paid the guy at the truck stop who swore he knew exactly what he was doing, had his uniform on, etc. Now his number is dis-connected and i can't find him. What a huge mistake I made!! A valuable learning lesson. It did have a lot more HP, but blew black smoke like crazy every time I throttled up.

BTW I made it back to Greer, SC today from Waddy, KY!!

Where is this fuse located that turns green?

Was this reply helpful?

Score 0
Add a comment

at the battery connections

Was this reply helpful?

Score 0
Add a comment

Have you checked for water in your fuel/water separator, or have you changed the fuel filters? Sounds like contaminated fuel to me.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

John Baxter will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 15

Past 30 Days: 53

All Time: 2,217