Site Navigation

Your Account

Choose Language

Discussion Topic

freightliner century auto stuck in gear

I have a 2001 Freightliner Century eaton fuller 10sp Auto that has been misbehaving lately! Whenever I am driving it there are times when it gets stuck in gear. Sometimes it happens daily sometimes it goes a few days without issues. When I am driving and get to 10th gear it sometimes gets stuck and starts flashing an "F" and will not downshift. Lately it's happening in ALL GEARS even Neutral!! When it's stuck in gear I pull over and let it sit for a while then the truck will reset and it will start and drive fine for a while. Other times it gets stuck and won't reset even after disconnecting the batteries!! When it does finally crank again it is stuck in neutral flashing an "F". This truck has had me stuck on the side of the road for hours simply frustrating!!! I have had to be towed three times!! I have only allowed Freightliner dealers work on the vehicle and so far they are clueless as well!! Memphis Freightliner replaced the transmission shift controller thinking that would fix the problem and I drove 70 miles and it happened again! Charlotte Freightliner replaced the x-y shifter, oem harness, transmission harness and two batteries and I drove 281 miles and it happened again! Kansas City Freightliner has replaced the ground harness and it's still happening!! Anyone out there have any idea what needs to be done to fix the problem? I have searched several forums and the entire internet with no luck! I see that several truckers have had this issue posted but didn't say how they fixed it....

Codes Trans Shft FNGR Rail / Sht Lo 130 060 04 and Trans Shft FNGR Gear / Sht Lo 130 059 04

HELP ME PLEASE!!!!!!!!!!!!!

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0
Add a comment

15 Replies

Those first generation auto shifts had that trouble when the came out. I remember guy getting stuck in truck stops. 2001 must be very close to first years those were made.

Was this reply helpful?

Score 0
Add a comment

i asked a guy earlier today about ur situation & he said to change the oil; use good synthetic oil in it & keep it changed @ about 300k; just repeating what he said

Was this reply helpful?

Score 0
Add a comment

sounds like my problem. I eventually got rid of the truck. Fixed it.

Was this reply helpful?

Score 0
Add a comment

You stated F will I had to replace XY shifter also TECU component it did exactly what your doing resolve the issue

Was this reply helpful?

Score 0
Add a comment

They have ordered the tcu for me waiting on it to arrive and be installed. Hope that does the trick!

Was this reply helpful?

Score 0
Add a comment

how long have u had the truck? how many miles it had on it when u bought it? how many on it now? when was the last time the oil was changed in it?

Was this reply helpful?

Score 0
Add a comment

Bought the truck in february 2012, I have put about 53k miles on it since I bought it. I don't know the last time the transmission oil was changed but I am having the transmission oil changed now while they are putting on the tcu. the truck has over a million miles on it some where like 1.3 million. the truck didn't start having these issues until after it had been towed. I had a driver in the truck who ended up getting arrested for some dumb mess he decided to do while parked at a walmart and then walmart had the truck and trailer towed while he was in jail. When I sent another driver to go pick up the truck and do a few loads is when the problem started. i don't know if the tow caused some issues or if the second driver was such a terrible driver that it was too rough on the tranny. All I know is my truck was never the same.

Was this reply helpful?

Score 0
Add a comment

please keep us updated if it was the cure for it or not. i'm really interested in how it turns out; i'm looking to buy a truck with an ultra-shift & don't really need any problems.

Was this reply helpful?

Score 0
Add a comment

I picked the truck up Tuesday (8/14) and I have driven about 800+ miles so far with no issues. They ended up replacing the TECU , Ground Harness and I had them change my Transmission oil as well as engine oil/fuel filters...hopefully I am done with repairs on this truck.

Was this reply helpful?

Score 0
Add a comment

I have a 2005 freightliner columbia smart shift truck with Eaton transmission thats having kind of the same issue. My problem is whenever i come into traffic stops it would get stuck in the second gear and will not shift up at all regardless if its manual or auto. I would have to shut the engine off apply the breaks wait anywhere between 20 mins and hours sometimes then it would work. This never happens when i am on the freeway at high speed.

Any pointers plz help. From researching online i see some folks saying its the XY shifter and the harness along with a software update.

Thanks

Was this reply helpful?

Score 0
Add a comment

Transmission harness first, xy shifter 2nd and main issue ECU..freightliner or Eaton cant tell you exactly whats wrong.eventually,you change all 3..tranny harness $950 part/labor , xy shifter $1700 part/labor,ECU $3300..

Update

Just happend to me.the professional freightliner made me spend almost $6k.they guessed.i ended up changing all 3.. ECU was not communicating with the other divices..my advice: SELL IT!!!thats what ill do!!FREIGHTLINER SERVICE ADVISOR ASK ME: do you know to drive stick shift?he answered my questions with a simple question

Was this reply helpful?

Score 0
Add a comment

Please do yourself a favor before replacing everything and check the yoke nut!!!! These transmissions are bad about the yoke nut loosening and it will throw a code for output shaft speed sensor data eratic, when the yoke gets loose it will fracture the sensor and throw theis code causing othe codes to appear also and it will hang up in whatever gear it's in at the time, even when you replace the sensor it will throw the code because of the vibration. The only way to check it is to pull drive shaft and put a socket on it, you cannot check it with a pry bar for up and down play because it most likely have any it will be in and out play and your carrier bearing will interfere with the old pry bar method. It will cause every thing that has happened in the above posts. Feel free to message me if you need further assistance

Was this reply helpful?

Score 0
Add a comment

1. Select Neutral, “N.” Turn the key OFF and let the transmission power down for a least 2 minutes.

2. Depress the brake pedal.

3. Release the parking brake.

4. Depress the clutch, but do not push in all the way to the floor or you will make contact with the clutch brake.

5. Select Neutral.

6. Turn the key to the ON position.

7. AutoShift will attempt to shift into Neutral once you turn the key ON, but you may have to slightly release the brake pedal to help let the torque off the driveline.

8. Once it reaches Neutral a solid “N” will appear on the Gear Display and the truck will start. If a dash still appears after this procedure, get the vehicle to a service center.

Was this reply helpful?

Score 0

Comments:

Just for those who still have the same problem

by

Add a comment

my 2007 columbia had the exact same problem,it ended up after alot of parts changeing being my clutch,had it replaced and drove it 400000 more miles an traded it in ,had 1.3 million on it.

Was this reply helpful?

Score 0
Add a comment

I have had the same problems intermittently for the last few weeks in my 2011 Cascadia. Before that I went two years with no problem like this. I was stuck blocking traffic or blocking loading docks until finally cleared itself mysteriously after half an hour or hours in some cases. I found that sometimes I could clear the fault codes and get moving again right away with this procedure from an Eaton doc: shift button to N, engine off, turn key to On then off six times within five seconds, ending in On position. Wait a few moments for gear indicator to cycle thru codes (88 is “running diagnostics”, 25 is “no codes”) until it finishes with N in gear indicator, then you can sometimes restart engine. But other times I've had to wait for "transmission to shut down" -sometimes 1/2 hour, two hours, 3 hours - before it will restart.

Was this reply helpful?

Score 0
Add a comment

Join the discussion

Charles will be eternally grateful.
View Statistics:

Past 24 Hours: 19

Past 7 Days: 122

Past 30 Days: 389

All Time: 21,931