Site Navigation

Your Account

Choose Language

Discussion Topic

u think u know engines, try this one!N-14 no fuel, NO START

N-14 not getting fuel! Truck had not been started for 3 mo's. jumped it off drove 10 miles. 1 week later no start. the 10 mile drive the truck had no power. Thought it was just old fuel at the time.

Fuel pressure 25 psi cranking, over 100 psi running on starting fluid.

fuel solenoid replaced

no codes

check valve cleaned

fuel filter replaced with new fuel. old fuel in filter NOT BLACK

Filter in pump checked, ok

ecm cooler checked, ok

cam censer replaced

cleaned all grounds

good batt. voltage 12.7 @ batt, 12.7 at fuel solenoid, 12.7 @ ecm

noid light seems dim, checked with new noid light still dim

2 fuses too injector harness, ok

NEW ECM

cam is rotating

no smoke out of exhaust! ITS NOT GETTING ANY FUEL AT ALL!

Question : If there was a voltage drop from ecm to injector would that be coded in ecm ??

Could the injectors get so clogged the truck would not start or smoke???

I am no dummy around trucks but this has me stumped !!

Reply to discussion Subscribe to discussion

Is this a worthwhile discussion?

Score 0
Add a comment

2 Replies

Pull off fuel lines if truck sat over summer bugs could build nests in the fuel tank vents when truck ran initially it could have collapsed the fuel lines. Try to free flow fuel out of tank from lines. Next I have seen governors corrode and stick but truck would still run at idle try primming pump with peice of fuel line and a funnel block return line so fuel doesn't bypass if pump has an air leak it will leak out fuel (would also explain no fuel) /

Was this reply helpful?

Score 0
Add a comment

,,, if you have that fuel pressure, the injectors are not injecting it. It seems unlikely that all 6 would go bad at once. The noid light is not a complete enough check, seek a more sophisticated check. It

Was this reply helpful?

Score 0

Comments:

,,, it might be possible that the wrap around filters on each injector might be clogged .

by

,,, oh yeah, make sure the pump filter is not installed upside , down .

by

,,, I run a fuel pressure gauge and have. 140 to 150 most of the time; however it will definitely start and run with 125 .

by

Add a comment

Join the discussion

terry will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 125